Excel 2016 Functions

A function is a preset formula in Excel that is intended to carry out a specific calculations, logical tests, formats, etc. in the cell in which it is located.

All functions begin with an equal sign (=) followed by the function's name and its arguments, which are contained inside parentheses. Some functions will only contain one argument, whereas others will contain multiple arguments, each separated by a comma.

Function Arguments

A function argument is any input that is given to a function. All arguments, required or optional, must be separated by a comma. The comma must be manually entered into the function in order to move onto the next argument in the function.

When fulfilling the arguments of a function, it is best to use a cell reference, if at all possible, versus manually typing data into the function.

Required Arguments

Some functions require one, or many, arguments before the function can be completed.

For example, the proper function requires a single argument which is text. To complete the function, the argument should contain a cell reference to the cell containing the text to be converted to a proper term.

If a function has more than one required argument, such as the SUM function, a comma must be typed to move to the next argument.

To perform a function with multiple arguments, start by typing an equal sign, followed by the function name, in this case sum. When the function name appears, either double click on the function name to select it, or use the arrow keys to highlight the function name and then hit the Tab key.

Note: When the function is selected, the text in the cell will be all capital letters with an open bracket. Below the cell the arguments of the function will appear.

The sum function can be used to add a range of cells, or individual cells throughout a worksheet\workbook. To add individual cells, navigate to the first cell and click on it, the function will now show the cell reference of the cell that was clicked on. Under the cell containing the function, Excel will highlight the argument that is being edited.
When the first argument has been completed, type in a comma to get to the second argument, in this case, number2. After the comma has been entered, the display under the function will update, showing the next portion of the argument that is being entered. Continue this process until all cells have been entered into the function. When the function is complete, enter a closed parenthesis and then hit the enter key.

To enter a range of cells into a function, move the cursor to the first cell in the range, then click, hold, and drag the mouse until all cells are selected. The function will now show the range of cells, which is indicated by two individual cell references separated by a colon.

Optional Arguments
Some functions may contain both required and optional arguments. When looking at a function, any argument that is in brackets [ ] is an optional argument.

The VLOOKUP function contains three required arguments (lookup_value, table_array, & col_index_num), and one optional argument, [range_lookup].

Cell reference
A cell reference is used to refer to a cell on a worksheet. A cell reference is the intersection of a column letter and the row number. For example, B2 refers to cell at the intersection of column B and row 2.

To find a cell’s cell reference, select a cell, and then look at the Name Box, which is located under the ribbon, on the left side of the screen. The Name Box will display the cell’s cell reference.
Enter a Function
To enter a function, enter an equal sign, the function name, open parenthesis, the required arguments, and then a closed parenthesis.

Functions may be entered by;
- Typing directly into a cell
- Typing in the formula bar
- Choosing a function from the Formulas tab.

In a cell or the formula bar
To enter a function into a cell or the formula, start the function by typing an equal (=) sign. As the name of a function is typed, Excel will list all functions that match the text being typed under the cell, or formula bar, containing the function.

To view a description of any of the suggested functions, use the arrow keys on the keyboard to highlight the function, or single click on the function name with the mouse. To select a function, use the arrow keys to highlight the function and then hit the tab key, or double click on the function name.

When a function is selected, the name of the function will be in all caps followed by an open parentheses. Under the function name will be a display of the arguments for the function, which may be text, numbers, a range, etc. The arguments that display will be related to the specific function that is selected.

When all of the required arguments are entered into the function, enter a closed parentheses and then by hitting the Enter key.

Tip: The closed parenthesis is not required to be entered to complete a function. After all required arguments have been entered into the function, simply hit the Enter key to complete the function.
Formulas tab

All Excel functions are located on the Formulas tab. On the Formulas tab, functions are separated into several categories; text, financial, Math, etc. To see a list of the functions contained in a category, click on the category dropdown.

To enter a function using the Formulas tab, place the cursor in the cell to contain the function and then navigate to the Formulas tab. Click on a category dropdown to view the available functions and then click on the appropriate function to select it.

Another option to insert a function is to use the Insert function button. The insert function option allows users to search for a description of what they want to do instead of having to know the name of a function. Excel will list all functions that match the description searched for in the middle of the window.

Click on a function name to view a description of the function. To choose a function, double click on the function name, or select the function and then click the OK button.

After selecting a function, from either a category dropdown or the Insert Function option, Excel will display the function argument window. Each argument in the function will display as a separate entry on the window. Click on the textbox next to each argument to display a description of the data needed for the argument. To enter the data for an argument, type in the data into the textbox, or select the corresponding cell within the sheet.

When all required arguments are entered, click on the OK button to complete the function.
Functions to Format Text
The syntax for these functions is very similar, it is the function name, remember, all functions must start with an equals (=) sign, followed by (text). (text) is the cell reference of the text to be converted.

Upper
Converts all characters within a string of text to Upper case

The syntax for upper is: =Upper(text)

Lower
Changes all characters in a string of text to lower case.

The syntax for lower is; =Lower(text)

Proper
Changes the first letter in a string of characters to upper case while the remaining characters are converted to lower case.

The syntax for proper is: =Proper(text)

Trim
Removes all extra characters from a string of text leaving only a single space between words.

The syntax for trip is: =Trim(text)

Calculating Functions
When using calculating functions, the arguments will contain (number1, number2,…). The argument may consist of individual cells separated by a comma, or a range of cells.

Sum
Returns a total of the numbers within cells.

The syntax for sum is: =SUM(number1, number2,...)

Average
Returns the average of the numbers contained within cells.

The syntax for sum is: =AVERAGE(number1, number2,...)

Min
Returns the smallest number within a set of numbers.

The syntax for min is: =MIN(number1, number2,...)

Max
Returns the largest number within a set of numbers.

The syntax for min is: =MAX(number1, number2,...)
Copy and Paste Function
There are a couple of options when copying and pasting a function. Before being able to copy and paste a function, users must understand how cell references work.

Relative Cell Reference
By default, Excel uses relative cell referencing, which means the cell references change in relation to a functions new location as the function is copied or moved.

For example; Excel reads the formula in cell C1 as “add the number in the cell located two columns to the left to the number in the cell located one column to the left”. When the formula, which appears as =A1+B1, is copied to the cell below, it performs the calculation using the same pattern, but updates the formula to reflect the appropriate cell addresses, =A2+B2.

AutoFill a Function
Autofill is the quickest and easiest way to copy a function to adjacent cells.

To copy a function to an adjacent cell, select the cell that contains the function and then navigate to the lower right side of the cell until the cursor turns into a Solid Plus icon. Click, hold and drag the cursor over the adjacent cells to copy the function.

Since relative cell references are used, the copied functions will update as the function is copied.

Copy & Paste a Function
The Copy & Paste option is best used when a function is being copied to a non-adjacent cell. When copying a function into a new location, the cell data (arguments) being used by the function in the new location must consist of the same amount of cell data as the original function.

For example, if the original function is adding the two cells to the left of the function location together to produce a total, the new location must have two cells to the left of the cell containing the function. If there are not two cells to the left of the cell containing the function, an error will appear.

In the example on the right, the original formula is looking for two cells to the left of the current location to be added together. When that formula is copied into a new location with only one cell to the left, an Invalid Cell Reference Error populates. What this means is the new location is not able to access the same amount of cells as the original formula, so the formula can’t be performed.

To copy & paste a function, select the cell that contains the function and then use the copy shortcut of Ctrl-C, or click on the copy icon located on the Home tab. Navigate to the new cell location and paste the function by using the Paste shortcut, Ctrl-V, or by clicking on the Paste button on the Home tab.
Copy and Paste Function Values (Results)
When copying and pasting cells that contain functions, Excel will paste the function, not the result produced by the function. To paste the result of a function into a new location, the Paste Special option must be used.

Select the cell containing the function and use a copy (Ctrl-C) command to copy the cell contents. Right click on the new cell to paste the results and then click on the Values icon, which is located under the Paste Options area, to paste the values of the formula in the new location.

The following options are available when pasting values by selecting the Paste Special...option from the right click menu;

- **Values** – Pastes the values of the copied data.
- **Values & Number Formatting** – Pastes formulas and number formats from the copied cells.
- **Values & Source Formatting** – Pastes the values and the formatting from the copied cells.

To get a live preview of how the data will appear when it is pasted, navigate over one of the Paste Options icons.

**Note:** Another way to paste the results of a function, is to use the Paste button from the Home tab. On the Paste button dropdown, the select Paste Special option.

On the Paste Special Window, select the Values radio button, and then click OK.
Name a cell
By default, all cells are referred to by their cell reference. When creating functions over multiple sheets it can be difficult to remember exactly what cell is to be included in a function. By assigning a descriptive name to a cell, creating formulas with cell references can be much easier.

Name Box
To name a cell, click on the cell to name. Navigate to the Name Box, which is located to the left of the formula bar, and type in a new name for the cell. Hit the Enter key to accept the new name.

Note: Cell Names must be unique and cannot contain any spaces. By default, cell Names may be used throughout the entire workbook, but they can be limited to an individual sheet via the Name Manager.

Define Name
Another way of naming a cell or range is to select the cell or range, click on the Formulas tab, and then click on the Define Name icon. On the New Name Window, provide a unique name for the cell/range in the Name textbox. On the Scope dropdown, there is an option to specify where this cell or range can be used, either for the entire workbook, or a specific worksheet in the workbook.

Note: The default setting is for the Name to be used in the entire workbook.

Use Named Cells
Named cells work just as a cell reference would, so they can be used simply as a reference to the data in a cell, or in a formula or function.

To refer to the value in a named cell, type an = sign and then start typing in the name given to the cell. Excel will populate the cell names and functions that fit the text that is being typed. When the named cell appears, click on it to select it, just as if it were a function.

To use a named cell in a formula or, start by typing an = sign. Select the named cell, enter in a calculation and then start typing either another named cell, a cell reference, or a number.

In this example, we are subtracting AdamExpenses from AdamSales to produce a revenue.
Cell ranges may also be named instead of individual cells. To do this, select the range, and then type a name within the Name Box, just as you would when naming a cell.

When naming a cell range, functions may be used on the entire range, instead of individual cells. For example, if a range of sales figures is names, a sum function with the named range can be used to display a total on a different sheet, instead of typing in individual cell references.

=SUM(BridgetSales)  $3,895.00

**Name Manager**
To view a list of all named cell in a workbook, navigate to the Formulas tab and click on the Name Manager icon. The Name Manager window will populate displaying all named cells and ranges, their value, location (Refers To), and Scope.

**Edit Named Cell**
To change the name or the location (Refers to) of a named cell, select the named cell in the list on the Name Manger and click on the Edit button.

**Delete Named Cell**
To delete a named cell, select the named cell from the Name manager and click on the Delete button.
Round Functions
Excel has a few different rounding formulas, depending on how the data is intended to be rounded and displayed.

RoundUp
Rounds a number up, away from zero.

The syntax is: \( \text{RoundUp(number, num_digits)} \)
- **Num_digits** - the number of digits to round from the decimal place.

Example:
- \( 1252 = \text{RoundUp}(F19, -2) \)
- \( 1300 = \text{RoundDown}(F18, -2) \)

RoundDown
Rounds a number down, closer to zero.

The syntax is: \( \text{RoundDown(number, num_digits)} \)
- **Num_digits** - the number of digits to round from the decimal place.

Example:
- \( 1252 = \text{RoundDown}(F18, -2) \)
- \( 1200 = \text{RoundDown}(F18, 0) \)

Round
Rounds a number to a specified number of digits.

The syntax is: \( \text{Round(number, num_digits)} \)

To determine which number to round to, enter a number into the num_digits portion of the round function arguments.

<table>
<thead>
<tr>
<th>Number To Round</th>
<th>1234.1234</th>
</tr>
</thead>
<tbody>
<tr>
<td>num_digits Value</td>
<td>-3 -2 -1 0 1 2 3 4</td>
</tr>
<tr>
<td>thousands</td>
<td>hundreds</td>
</tr>
</tbody>
</table>

**Num_digits** - number of digits to round from the decimal place.
- Positive **Num_digits** number - will round to the right of the decimal place
  - \( 16 = \text{ROUND}(A16, 2) \) would round the number in A16 to 2 decimal places
  - \( 222.2222 = \text{ROUND}(A16, 2) \)
  - \( 222.22 = \text{ROUND}(A16, 2) \)
- Negative num_digits number - will round to the left of the decimal place
  - \( 17 = \text{ROUND}(A17, -2) \) would return the number in A17 to the 100\(^{th} \) place
  - \( 333.3333 = \text{ROUND}(A17, -2) \)
  - \( 300 = \text{ROUND}(A17, -2) \)
**MRound**
Returns a number rounded to a desired multiple

The syntax is: \( =\text{MRound}(\text{number, multiple}) \)
- **Multiple** - the multiple to which to round the number
  - To round to a multiple of 5 (a number divisible by 5), enter in a 5 for the multiple.
  \[ \text{=MROUND(L3, 5)} \]
  \[ 2222 \]
  \[ =\text{MROUND}(L3, 5) \]
  \[ 2220 \]

**Count Functions**
Excel has a couple different counting functions that will give various results based on the data in the cells.

When using the following calculating functions, the arguments will contain (value1,value2,...). The argument can either consist of individual cells separated by a comma, or a range of cells.

**Count**
The Count Formula will return the number of cells within a range that contain a Number.

The syntax is: \( =\text{COUNT}(\text{value1},\text{value2},...) \)

**CountA**
The CountA Formula will return the number of cells within a range that are not blank. It will count both numbers and text.

The syntax is: \( =\text{COUNTA}(\text{value1},\text{value2},...) \)

**CountBlank**
The CountBlank Formula will return the number of cells within a range that are blank.

The syntax is: \( =\text{COUNTBLANK}(\text{value1},\text{value2},...) \)

**CountIf, SumIf, AverageIf**
CountIf, SumIf, & AverageIf will perform calculations, only if certain criteria are met.

**CountIf**
The CountIf Formula will count a range of cells if the cells meet a specific criteria.

The syntax is: \( =\text{COUNTIF}(\text{range},\text{criteria}) \)
- **Range**: The range of cells that contain the specific value or text string to be counted.

[Image of a spreadsheet with cells containing text and numbers, and a formula bar showing COUNTIF usage]
• **Criteria:** the specific number, text or expression that must be met to be counted.
  
  o **Note:** If the criteria portion is text, it must be contained inside double quotations “ “. Text is not case sensitive.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>ACNS</td>
<td>36</td>
<td></td>
</tr>
<tr>
<td>CHEM</td>
<td>44</td>
<td></td>
</tr>
<tr>
<td>COB</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td>CHEM</td>
<td>49</td>
<td></td>
</tr>
<tr>
<td>ACNS</td>
<td>45</td>
<td></td>
</tr>
<tr>
<td>COB</td>
<td>40</td>
<td></td>
</tr>
</tbody>
</table>

=COUNTIF(B2:B7,"acns")

SUMIF

The SumIf Formula will add the values within a range together only if specific criteria are met.

The syntax is: =SUMIF(range, criteria, [sum_range])

• **Range:** The range of cells that contain the specific value or text string to be totaled.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>ACNS</td>
<td>36</td>
<td></td>
</tr>
<tr>
<td>CHEM</td>
<td>44</td>
<td></td>
</tr>
<tr>
<td>COB</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td>CHEM</td>
<td>49</td>
<td></td>
</tr>
<tr>
<td>ACNS</td>
<td>45</td>
<td></td>
</tr>
<tr>
<td>COB</td>
<td>40</td>
<td></td>
</tr>
</tbody>
</table>

=SUMIF(B2:B7)

SUMIF(range, criteria, [sum_range])

• **Criteria:** the specific number, text or expression that must be met to be counted.
  
  o **Note:** If the criteria portion is text, it must be contained inside double quotations “ “. Text is not case sensitive.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>ACNS</td>
<td>36</td>
<td></td>
</tr>
<tr>
<td>CHEM</td>
<td>44</td>
<td></td>
</tr>
<tr>
<td>COB</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td>CHEM</td>
<td>49</td>
<td></td>
</tr>
<tr>
<td>ACNS</td>
<td>45</td>
<td></td>
</tr>
<tr>
<td>COB</td>
<td>40</td>
<td></td>
</tr>
</tbody>
</table>

=SUMIF(B2:B7,"cob")

SUMIF(range, criteria, [sum_range])

• **Sum_Range:** This is the range of cells that you want to be added together if the criteria is met.
  
  o If this argument is omitted, the cells in range will be used to produce the total.
**AVERAGEIF**

The `AVERAGEIF` Formula will average the values within a range only if specific criteria are met.

The syntax is: `=AVERAGEIF(range, criteria, [average_range])`

- **Range:** The range of cells that contain the specific value or text string to be averaged.

  ![Range Example](image1.png)

- **Criteria:** the specific number, text or expression that must be met to be counted.
  - **Note:** If the criteria portion is text, it must be contained inside double quotations “ “. Text is not case sensitive.

  ![Criteria Example](image2.png)

- **Average_Range:** This is the range of cells that will averaged if the criteria is met.
  - If this argument is omitted, the cells in range will be used to produce the average.

  ![Average Range Example](image3.png)
Convert

The Convert function will convert a number from one measurement to another. For example, temperature in Fahrenheit can be converted to Celsius, or weight in pounds can be converted to kilograms.

When using the convert function, users have to know the specific codes that Excel uses for each unit.

Here are some common unit codes;

- Miles = “mi”
- Kilometers = “km”
- Foot = “ft”
- Yard = “yd”
- Meter = “m”
- Degree Fahrenheit = “F”
- Degree Celsius = “C”


Note: Unit codes are case sensitive and must be contained in double quotation marks “ “.

The syntax for convert is: =CONVERT(number,from_unit,to_unit)

- Number - Value to be converted
- From_unit – Units that the number portion is currently formatted to.

Note: The from_unit must be in double quotation marks “ “ and is case sensitive.

  - When the from_unit portion of the argument is selected, Excel will populate a list of unit codes.

    Search through the list by using the scroll bar to find the correct code. To select a code, double click on it, or highlight the code and press enter.

    The unit code may be manually enter, but make sure the code is in double quotes and remember it is case sensitive.
To_unit – the new unit to convert number to

<table>
<thead>
<tr>
<th>Miles &quot;mi&quot;</th>
<th>Kilometer &quot;km&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>25</td>
<td>=CONVERT(A2, &quot;mi&quot;, &quot;km&quot;)</td>
</tr>
<tr>
<td>55</td>
<td>=CONVERT(number, from_unit, to_unit)</td>
</tr>
</tbody>
</table>

Note: The to_unit must be in double quotation marks “ “ and is case sensitive.

- When the to_unit portion of the argument is selected, Excel will populate a list of unit codes.

Search through the list by using the scroll bar to find the correct code. To select a code, double click on it, or highlight the code and press enter.

The unit code may be manually enter, but make sure the code is in double quotes and remember it is case sensitive.

Substitute

The substitute function can be used to replace a character, or set of characters, within a string of text.

The syntax for substitute is:  

=Substitute(text, old_text, new_text, instance_num)

- **Text**: The text where the substitution is going to take place

- **Old_text**: The existing text that is being replaced.
  - The letter(s) must be in quotes. “a” “Aa” and are case sensitive.

- **New_text**: The new text that will replace the old_text
  - The letter(s) must be in quotes. “a” “Aa” and are case sensitive.

- **Instance_num**: Optional. Specifies which occurrence of old_text to be replaced with new_text.
  - If every instance of the text is to be replaced, the instance_num may be left blank
  - If an instance_num is entered, only that instance of old_text is replaced.
    - If only the second instance of the text is to be replaced, enter in a 2
Concatenate
Concatenation combines the content of cells, or manually entered data, into a single cell.

The syntax for Concatenate is: $=\text{CONCATENATE}(\text{text1}, \text{[text2]}, \text{[text3]}, \text{...})$

- **text1**: The first string to join. This may be a cell reference, a number, or manually entered text.
  - Manually entered text must be entered in double quotation marks “ “.
- **text2, text3, etc.**: Additional strings to join to text1. This may be a cell reference, a number, or manually entered text.
  - Manually entered text must be entered in double quotation marks “ “.

When text strings are concatenated, excel will not insert a blank space between text1 and text2, or text2 and text3. To insert a blanks space or any type of punctuation it must be typed into an argument contained in double quotation marks.

For example, to insert a comma and a space between the text in cell A2 and B2. Start the concatenate formula with an equal sign (=) followed by the concatenate term. Hit the tab key to enter the function. After typing in, or clicking on, the cell reference of A2, hit the comma key to move to the text2 argument. Since a comma and a space are required, they must be typed in double quotes.

$$=\text{CONCATENATE}(A2, \text{"", ",")}$$

Now, hit the comma key, which must be outside of the double quotes, to move into the text3 argument and then type in, or click on, the cell reference of B2.

$$=\text{CONCATENATE}(A2,\text{"", ",", B2}$$

To manually enter a string of text, make sure to include any needed spaces and all text within double quotation marks, “ manually entered text “.

In the example below, the text from A2 is being combined with the text in B2 with the manually entered text, “ is employed by “ between the two strings of text.