Excel 2016 Level II

Increase/Decrease Excel Values
Excel allows you to permanently increase or decrease a list of values by using the Paste Special option. To do this, enter the number that you want to change the list by into any blank cell. If you are looking to increase by 25%, enter 1.25, decrease by 25%, enter 0.75. Now, copy that cell by using the keystroke Ctrl-C.

Make a selection of the range that you want to change. When you have the selection made, go to the dropdown under Paste on the ribbon and select Paste Special.

In the Paste Special Window, click on the Multiply radio button and then click OK. Your values have now been increased by 25%.

You can also use this to Add, Subtract or Divide.

Note: You may use whole numbers to perform these functions.

Using Multiple Worksheets and Workbooks
If you have information that needs to be inserted on multiple worksheets, you can use grouping to select multiple worksheets and key in the data once. The data will appear in the exact same cell location, with all formatting being the same, except on a different worksheet.

Grouping Worksheets
To group worksheets, click on the first worksheet tab to be in the Group then press and hold the Ctrl key and click on the other worksheet tabs that you want to add to the group.

The Grouped worksheets will display with a white color in the worksheet tab area. Worksheet tabs that are not grouped will have a grey background. When the sheets are grouped, anything you enter on the worksheet, will be duplicated on every other worksheet in the Group.
**Ungrouping Worksheets**

To ungroup worksheets, click on a worksheet tab that is not within the group. (One with a grey background.)

You may also right click on a worksheet within the group and then select Ungroup Sheets.

**Copying Worksheets between Workbooks**

Worksheets can be copied between workbooks as easily as copying within a workbook. When copying data between workbooks, both data files must be open.

**Tip:** Worksheets containing formulas or charts based on data elsewhere in that workbook might become inaccurate when moved to a new workbook.

**Steps:**
1. Open workbooks
2. Navigate to the sheet to be copied.
3. Right-click with the mouse on the worksheet tab and select Move or Copy.
4. From the Move or Copy dialog box, select the workbook to be copied to, location in the workbook where you want the copy located. **(Note:** The copy will be placed to the right of the selected worksheet. Click on the Create a copy checkbox if you want a copy.
5. Select the OK button.

**Changing Worksheet Tab Colors**

You can change the color of a worksheets tab to help organize your worksheets and make your workbook easier to navigate.

To change the color, right click on one (or more) worksheet tabs and select Tab Color. There are several options for the colors preselected for you, or you can also color by selecting the More Colors option.

To remove a color, select the no color option.
Protecting Worksheets

There are a couple of ways to protect your worksheet. You can have it set so the recipient can see all of the data, but cannot adjust any of the data, or you can select cells that the recipient will be able to adjust.

By default, all cells within Excel are locked, meaning, if you protect the worksheet, none of the cells are able to be typed in because they are locked. To protect a worksheet so that it can only be viewed, click on the Review Tab, then select the Protect Sheet icon.

You will have a couple options on the Protect Sheet dialog box. The defaults will work fine for protecting the entire sheet. Make sure you look over the options because there may be an option listed that you would like the users to be able to do.

When you have made your selections, click OK.

Your worksheet is now protected against any editing, unless you give out the password. Anyone who has the password can unprotect the worksheet and then edit the document.

To unprotect the worksheet, click the Unprotect Sheet Icon on the Review Tab. Excel will ask for the password. If the correct password is typed, you are able to edit the document. You must protect the worksheet again if you want it protected again.

Tip: If you do use a password to protect the sheet, make sure to remember that password. If you forget the password, you will not be able to edit the information.
Protecting parts of a worksheet
If you want an end user to be able to edit some of the information within the worksheet, you will have to unlock the cells that you want to be edited. To do this, highlight the Cells that you want to be edited. When you have your selection, right click within that selection and select Format Cells.

In the Format Cells dialog box, click on the Protection tab, then click on the Locked checkbox so it is unchecked.

Next, protect the worksheet as you did in the previous section. All cells except the ones that are unlocked will be protected. Users are now able to enter data into the unlocked cells only.

Filtering Data
The ability to filter data in a worksheet is very powerful. You can easily filter data by using the Sort and Filter icon from the Editing Group on the Home tab, select Filter tool.

Adding a Filter adds a drop down list to each column.

Tip: The Filter tool can only be applied to Columns and NOT Rows.

By default, the filter is set to display all data. Click on the Select All checkbox to deselect it and click on the check boxes of the items you want to display. Click on OK.

You can then apply a second and/or third filter (nest) by selecting the drop down filter for a different column and choosing the filter option.
You will be able to tell which columns have been filtered because the icon will look a little differently on a filtered column vs an unfiltered column. An unfiltered column has an arrow, a filtered column has a small arrow and a filter.

When you have filtered your data, the status bar on the lower left side of the window will indicate the amount of records you are displaying to the amount of total records.

A filter can be removed by going into each filtered column’s dropdown and selecting Clear filter from “Column Name”.

A filter can also be cleared by going to the Sort & Filter dropdown menu and select Clear.

**Searching for Data with a Filter**

You are able to search for specific information within a filtered column. To search for a specific piece of data, go into the column where you are looking for the data, click on the dropdown arrow and start typing in the search text box. As you type, excel will show the data that matches what you are searching for.
Auto Filtering
Excel has built in, column specific filtering. This filtering option is specific to the type of data that is displayed in the column. From this filter option, you are able to search for text that only contains a certain character or character, the top ten numbers, numbers between certain numbers, etc.

For example, if you have a column containing numbers you are able to search for numbers within the column that are between a specific range of numbers. To start the filter, click on the dropdown for the column where you want your range. Since this is a number column, you will see Number Filters. (Text will display Text Filters, Date – Date Filters) There will be various options, depending on the type of data within the column. Choose the Between Option.

The Custom AutoFilter window now displays where you are able to put in your range of numbers. Each end (high and low) has options for how you want to compare the data (does not equal, is less than, etc.) Select your options, then click OK.

That data that displays is only the data the meets the requirements.
Tables

Tables can be very beneficial when you are working with large amounts of data and the data is being added and subtracted from. Tables will give you a nice visual layout or your data and will allow for your data to grow without effects to any formulas that are created on the data.

Benefits of using tables:

1) Integrated Filter and Sort functionality
2) Header row remains visible while scrolling, if your cursor is within the Table
3) Automatic expansion of the table when new data is entered
4) Automatic reformatting of the table when new data is entered
5) Automatic adjustment of formulas, charts when new data is entered

To convert your data into a Table, make sure your cursor is someplace within the data, navigate to the Insert Tab and select Table. Excel will display a Format As Table dialog box confirming your selection in which the formatting should be applied.

Tip: When selecting the option for My table has headers, Excel will automatically add column filtering when applying the format as a table.

You will now see that the look of the data has changed. Excel has added colored rows for easy navigation and added in filtering for each column.

TIP: Any time you are working in your table your cursor must be someplace in the table itself. To verify you are adding options to the table, make sure you see the Table Tools Design Tab on the ribbon. This will indicate that the table is selected within the worksheet.

On the lower right corner of the table, you will see a dark icon. This icon is the Sizing Handle. The sizing handle indicates the bottom and right sides of the table. It also you to drag the table to add in more rows and columns, but this is not advised as you may include blank data by increasing the table size this way.
The formatting options should now be applied to the selected text. You can easily change the color scheme of your selected table by choosing a different color scheme from the Design Tab within Table Tools. On the right hand side, you will see Table Styles, click on the dropdown for more options.

3-D Reference
A 3-D reference is a reference/formula that refers to the same cell or range of cells on multiple sheets. A 3-D reference is useful when you want a summary of data from multiple worksheets that follow the same pattern and cells on each worksheet contain the same type of data.

Steps to insert 3-D Reference
1. Position the cursor in the cell that will hold the value
2. Start typing part of the formula
   Example: =Sum(
3. Click on the first worksheet tab that should be used in the calculation
4. Hold the Shift key and click on the last worksheet to be used in the calculation (this will select a range of worksheets)
5. Select the cell or range containing the values to calculate
6. Complete the formula by Press Enter.

Result: =SUM(John:kylie!B5) For the worksheets John through Kylie, sum cell B5 from each worksheet and display the result on the page/cell where the formula was created.
**Watch Window**

When cells are linked, any changes to the “source” cell will automatically update the linked cells. The Watch Window can be used as an observation tool to see cell references are being updated.

The example above contains summarized data from the worksheets: John, Sarah, George and Kylie. Add a Watch Window to observe the effect of cells being updated.

**Steps to insert a Watch Window**

1. Position the cursor in the cell to which you want to add a Watch Window. For this example, click on the Total tab and position the cursor in cell B5.
2. Click on the Formulas tab, select the Watch Window icon.
3. Click Add Watch to open the Watch Window dialog box. By default, Excel will add the cell reference of the active cell. If this isn’t the correct cell, navigate back to the worksheet and select the correct cell by clicking on it. Now click on the Add button.

The watch window will show you the value of the cell that you placed the watch on. You are now able to navigate to one of the cells that is contained in the formula and change a number to test the results. When you change a number contained in the formula, the Value should change reflecting the changes made. You can add as many watches as you would like to the Watch Window.

The Watch Window remains visible; no matter which worksheet is active. To close the Watch Window, click on the “X” in the upper right corner. Delete an item from the Watch Window by selecting it and pressing the Delete key.
Linking Workbooks
Linking workbooks allows you to create a link in one workbook that refers to a cell, a range of cells, or name in another workbook. Linked workbooks can be very helpful when providing a summary worksheet that is retrieving data from multiple workbooks in different locations.

Syntax for linking workbooks
=FORMULA('[workbookname.xlsx]worksheetname'!Cell or Range)

Example:  =SUM('[3D Formula.xlsx]LinkBack'!$B$3:$E$3)

Which means, take the sum of cells B3 to E3 from the Summary of Sales workbook, LinkBack tab.

Steps to create External Links
The workbook that contains the formula is called the “destination” workbook. The workbook to which the formula refers is call the “source” workbook.

1. Open the destination workbook
2. Select the cell that will hold the formula
3. Type an = (equal) sign in the cell and then a formula if you are using one and hit Tab
4. Navigate to the source workbook and select the cell(s) you want the formula to refer to.
5. Press Enter

Any time you update the information on the source workbook, the data will be updated on the destination workbook, as long as there is a good Link, even if one of the workbooks is closed.

Tip:  By default, Excel is configured to prompt the user when a workbook that has external links requires those to be updated. You can either Update the links from this Security Warning when you open Excel, or you may update it by using the Edit Links Icon on the Data Tab.

To update the links from within Excel, make sure you are in the destination workbook. Click on the Data Tab and then click on the Edit Links icon.
From the Edit Links window, you are able to check the status (opened or closed), of the linked workbook(s) (you may have to click on Check Status), you can change the source workbook, open the Source workbook if it is not open or break the link to the workbook.

Maintaining Workbook Links
If the source and the destination workbooks are both open and you change a file name, the linked references will get updated. If both sources aren’t open, start in the destination workbook, the workbook which contains the formula, select the Data tab and then select the Edit Links icon in the Connections Group. From the Edit Links dialog box, select the Change Source button. Navigate and point to the new file name. Click the OK button to redirect the link. Click on the Close button to complete the task.

Goal Seek
Goal seek is a part of Excel’s What-If Analysis tool. Goal seek is used to attain a desired result from an existing formula within Excel when you are unsure of what a value needs to change to in order get the result we need.

For example, if we have a total of 10 tests and we have the result of the first 9 and the Average is an 89.11. To get an A in the course, what do we need to score on the final test? We can easily enter in numbers until we get our answer, or we can use Goal Seek to produce our results.

<table>
<thead>
<tr>
<th>Test 1</th>
<th>80.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test 2</td>
<td>98.00</td>
</tr>
<tr>
<td>Test 3</td>
<td>92.00</td>
</tr>
<tr>
<td>Test 4</td>
<td>90.00</td>
</tr>
<tr>
<td>Test 5</td>
<td>96.00</td>
</tr>
<tr>
<td>Test 6</td>
<td>91.00</td>
</tr>
<tr>
<td>Test 7</td>
<td>82.00</td>
</tr>
<tr>
<td>Test 8</td>
<td>90.00</td>
</tr>
<tr>
<td>Test 9</td>
<td>83.00</td>
</tr>
<tr>
<td>Test 10</td>
<td></td>
</tr>
<tr>
<td>Average</td>
<td>89.11</td>
</tr>
</tbody>
</table>
To start a goal seek, select the cell that needs to meet a goal (the cell containing a formula), in this case, we want to select our Average score. Now navigate to the Data Tab, click on the What-If Analysis icon in the Forecast group and select Goal Seek.

On the Goal Seek window, there will be text boxes for the following;

- **Set Cell** – This is the cell that we want to change to the new desired value
- **To Value** – The value is the new desired value that we want to produce
- **By changing cell** – This is the cell that is going to change to give the new value

When all of the values are provided, click on the OK button.

Excel will run through iterations until it gets the result that you are looking for. You will see that the cells on the spreadsheet have changed to the new values. If you would like to keep these values, click OK. If you don’t want to change the values, click Cancel.
**Macros**

Macros are automated instructions or mini-programs that run inside of Excel. Macros can be created 2 ways;

1. **Record mouse clicks and keystrokes to be played back later**
   - **Advantages**
     - Requires no programming knowledge
     - Uses the Excel knowledge you already have
   - **Disadvantages**
     - You can’t modify a macro after you create it, unless you edit in the VBA
     - Recorded macros have no ability to make decisions
     - All clicks are recorded, including errors and corrections

2. **Write a program in VBA (Visual Basic for Applications)**
   - **Advantages**
     - You can modify the macros as much as you like
     - Macros can make independent decisions
     - Some tasks can be done only by programming
     - When you understand VBA for Excel, you can use this in other Office programs
   - **Disadvantages**
     - You need to learn the VBA language
     - After writing the code, you have to test and debug it
     - For simple tasks, programming can take more time than recording the clicks and keystrokes

**Developing a Macro**

To create a Macro, we need to make sure the Developer Tab is displayed in Excel. By default, the developer tab is not displayed in Excel.
To add the Developer Tab, click on File, Options, Customize Ribbon. In the Customize the Ribbon box, check the Developer checkbox and then click OK.

Next, we will want to Set Macro Security on Developer Tab. To do this, click on the Macro Security icon. Make sure the second option; “Disable all macros with notification” is selected.

This should be selected by default, but we want to make sure that the first button IS NOT selected. The reason for this is that there are people writing macro viruses that can cause harm to your computer and Excel, and Excel tries to protect itself against them. If you have at least Disable macros with notification, it means that when Excel sees that there is a workbook that contains macros, it will at least notify you that there are macros here, do you want to enable them or not? If you have that first radio button selected, you won’t even get a chance to run the macros.
**Absolute Referencing Macros**

One last thing we need to decide when recording macros is are we recording with relative references or not with absolute references?

For example, if you have cell A3 selected and you hit the down arrow the active cells go one cell down into Cell A4. When you are running the macro what happens if you're starting on Cell D3? When you hit the down arrow what's going to happen? Are you going to go straight down to Cell D4? That's a relative reference, or are you going to go literally to Cell A4, which is an absolute reference. So that's what you have to decide is will your navigation be exactly literally the cells that you are recording or will they be relatively going up or going down, left or right? For the purposes of this macro that we are going to record let's turn Relative References on.
**Recording a Macro**

To record a Macro, click on the Record Macro Icon on the Developer Tab.

The Record Macro dialog box comes up where you are able to name your Macro (the name may not contain any spaces), create a Shortcut keystroke, and decide where you want the Macro stored and an area for a Description.

**Tip:** If you are creating a shortcut, make sure you aren’t using an existing shortcut within Excel. If you do use a preexisting shortcut, the shortcut you create for your Macro will override the previous shortcut. Almost every option starting containing the Ctrl key and another key are taken.

**Personal Macro Workbook** is a specific file that Excel keeps your recorded macros in. The Personal Macro Workbook will open whenever Excel starts up but it will open up hidden, so it doesn't get in your way and there is no danger of you messing it up. If you do not have a Personal Macro Workbook, Excel will create it the very first time you select it.

**New Workbook** – This option will create a brand new workbook and put your macro in this new workbook. You would use this option if you intend on distributing your macro to other people.

When you have completed the Macro dialog box, click OK. Anything you do after you click OK will be recorded and stored in your Macro. To verify that you are recording, you will see that the Record Macro button is now a Stop Recording button.

**Tip:** It is more convenient to use shortcuts versus using your mouse to navigate through the workbook/worksheet.

**Handy Shortcuts**
- Ctrl-B – Bold
- Ctrl-U – Underline
- Use **arrow keys** to move up, down, left, or right
- Ctrl-Home - Navigates to cell A1
- Ctrl-Arrow - Moves the active cell in the direction of the arrow until the edge of a block of data is reached.
- Ctrl-C – Copy
- Ctrl-V – Paste
- Ctrl-F6 – Navigates to the next opened workbook
Running your Macro

To run your Macro, click on the Macro icon and then select the name of the Macro you want to run, and then click Run. If you created a shortcut, you can use that to run the Macro.

Saving your Macro

When you have produced your macro and you want to save the workbook with the file in it, you must do File, Save As. Select the location to save the file. From the Save As window, navigate to the Save as type dropdown and select the Excel Macro-Enabled Workbook option from the dropdown menu.