Excel Tables & PivotTables

A PivotTable is a tool that is used to summarize and reorganize data from an Excel spreadsheet. PivotTables are very useful where there is a lot of data that to analyze.

PivotTables are dynamic, meaning the data can be reorganized and redisplayed easily based on what the end result is to be. Even though PivotTables are dynamic, it is best to plan out the end result for the data, before creating a PivotTable.

It is best practice to format the data as a table before creating a PivotTable because if data is ever added to or deleted from the original data, a table will automatically adjust to allow for the newly added, or deleted data to be displayed in the PivotTable, as long as the PivotTable data is refreshed.

Tables
Tables are very beneficial when working with large amounts of data, especially if that data may potentially change. Tables give a nice visual layout of the data so it is easier to search out individual rows, sort and/or filter the data.

Benefits of using tables:
- Integrated Filter and Sort functionality
- Header row remains visible while scrolling, as long as the cursor is within the Table
- Automatic expansion and subtraction of the table when new data is entered
- Automatic adjustment charts when new data is entered
- Automatic reformatting of the table when new data is entered

To convert a block of data into a Table, place the cursor within the data. Navigate to the Insert Tab and then click on the Table icon.

Excel will populate the Format As Table dialog box, which will confirm the location of the data to be converted into a table, as well as an option to specify if the data contains headers. When the data location and the header option is selected, click OK.
The look of the data on the sheet will change slightly, with the addition of a more distinct header row, alternating colored rows, as well as with filtering/sorting options applied to each heading.

If any columns of the original data have formatting applied, that formatting will carry over to the data within the table.

**Table Sizing Handle**
On the lower right corner of the table, there is a dark icon, called the Sizing Handle. The sizing handle indicates the bottom, right side of a table.

**Table Tools**
Any time the cursor is within the table data, the Table Tools Design Tab will be displayed on the right side of the ribbon. To make any changes to a table, the cursor must be located within the table data.

To change the color scheme of a Table, make sure the cursor is within the table and then navigate to the Table Tools Design Tab. On the right hand side of the Design Tab is the Table Styles group. To select a new color, simply click on the color option to apply it to the table.

To view more options than what are displayed, click on the dropdown menu on the lower right corner of the Table Styles group.
Create a PivotTable
When creating a PivotTable, it is best practice to ensure the data does not contain subtotals or blank cells. Blank data may cause issues within the PivotTable by creating column names or cells to display as (blank).

Tip: It is best practice to convert the data into a table before creating the PivotTable.

Recommended PivotTables
Recommended PivotTables is a feature introduced to Excel 2013 which provides a few PivotTable options based on the data in a worksheet.

To use the Recommended PivotTables feature, make sure the cursor is within the data. Navigate to the Insert tab, and then select the Recommended PivotTables icon.

A new Recommended PivotTable window will appear showing the options that Excel is recommending for the PivotTable.

Users are able to click on each option to see a preview of how the PivotTable will display.

Recommended PivotTables can be a useful option to use for a starting point for a PivotTable, but it may not be the best option based on what is expected as an end result.

If none of the options are going to work, click on the Blank PivotTable button to create a Blank PivotTable button on the lower left side of the Recommended PivotTables window to create a blank PivotTable.

Tip: To view PivotTable Recommendations on an existing PivotTable, make sure the cursor is within the PivotTable. Navigate to the PivotTable Tools Analyze Tab and then click on the Recommended PivotTables icon.

Note: To make changes to a PivotTable, the PivotTable Tools tab must be active. If the PivotTable Tools tab is not active, move the cursor within the PivotTable.
Manual PivotTable

To create a manual PivotTable, make sure the cursor is within the table (data) on the worksheet. Navigate to the Insert Tab and then click on the PivotTable icon.

Note: Users may also select the data on the worksheet, navigate to the Insert tab, and then click the PivotTable icon.

On the Create PivotTable window, make sure the correct table, or data range, is selected in the Select a Table/Range textbox. If the range is incorrect, move the cursor into the Select a table or range textbox and then highlight the correct data from the sheet.

On the bottom of the Create PivotTable window, choose the location to place the PivotTable, either a new worksheet, which will be automatically created to the left of the current sheet, or an Existing Worksheet.

If the Existing Worksheet option is selected, click within the Location textbox and then navigate to the sheet and cell location to insert the PivotTable.

When all of the options have been selected, click on the OK button to create the PivotTable.
The PivotTable will be inserted onto a sheet and will look similar to the screenshot below.

The PivotTable consists of a blank PivotTable on the left side of the screen, the PivotTable Fields (column headings from the original data), on the top, right side of the screen, and the PivotTable areas on the bottom right side of the screen.

**Note:** To make changes to a PivotTable, the PivotTable Tools tab must be active. If the PivotTable Tools tab is not active, move the cursor within the PivotTable.
Add Fields to a PivotTable

To make a PivotTable, fields must be added to the PivotTable areas.

To automatically add a field to a PivotTable, click on the checkbox next to the Field name and Excel will place the field in the area that it sees is the best fit for that field.

**Note:** This can be a good way to start working with PivotTables, but typically a manual process is a better option for adding fields to a PivotTable.

To manually add a field, click and hold on a field name and then drag the name into one of the four PivotTable areas listed below the field list.

If the PivotTable isn’t displaying the information as intended, users are able to drag fields into any of the other field areas on the fly by clicking and holding on a Field, and then dragging the field name into a new area.

**Tip:** Not every field has to be used when creating a PivotTable, there may be times when only 2 or three fields are used, and there may be times when all fields are used. This is a major benefit of PivotTables, they are dynamic so there is no right answer, it all depends on what information is to be displayed.

**PivotTable areas**

1. **Filters** – Top-level filters that are displayed above the PivotTable
   - Filters can be used to only display results that meet a certain criteria
   - For example, only display results for a single region vs all regions

2. **Columns** – Display as column labels across the top of the PivotTable, with the data displayed below. Field names on the top of the columns area will display on the top within the PivotTable.

Columns may have several fields added to them to nest the column labels.

**Single Field within Columns**
3. **Rows** – Display as row labels on the left side of the PivotTable. Rows may also have several fields to nest the row labels.

4. **Values** – Displays as a calculation of the data in the field. The calculation can be a sum, count, average, etc.
Remove Fields from a PivotTable
To remove a field from a PivotTable, uncheck the field name from the Choose fields to add to report area section of the PivotTable Fields, or click, hold and drag the field name from the areas section back into the Fields section.

Changing the Data Source
If data is added to the PivotTable source data, and if the PivotTable was created without using a table, a new data source may have to be selected to ensure the PivotTable contains the newly added data.

To change the original data source, make sure the cursor is within the PivotTable, navigate to the PivotTable Tools Analyze tab and then click on the Change Data Source button. Select the new data range from a, which may be on a different worksheet, or workbook and then click on the OK button.

Tip: The Change Data Source option may also be used to verify where the original data is located.

Note: If the new data is coming from an external data source, a new PivotTable will have to be created and the option for External Data Source will have to be selected in the Create PivotTable dialog box.
Delete a PivotTable from a Worksheet

To delete, or clear all of the data from, a PivotTable make sure the cursor is in a cell in the PivotTable. Navigate to the PivotTable Tools Analyze tab, in the Actions group, click on the Clear button, and select the Clear All option.

Another way to clear data from a PivotTable would be to deselect all of the fields in the PivotTable task pane.

PivotTable Options

The settings for how a PivotTable will display by default are located PivotTable options menu. To get to the PivotTable options, make sure the cursor is in the PivotTable data, navigate to the PivotTable Tools Analyze Tab. On the far left side of the window, select Options, which is located under the PivotTable name textbox.

Tip: Another way to access the PivotTable options is to right click within a PivotTable and then select PivotTable options.

A few settings to check out are:

- **Sorting** – Located on the Display Tab. The default setting for how the data is sorted is based on how the data is displayed in the original data source. To sort all data alphabetically, select the Sort A to Z option on the bottom of the tab.

- **Refresh Data** – By default, the data within a PivotTable will not update unless a user manually refreshes the data. On the Data tab, there is an option that will automatically refresh the PivotTable data anytime the file is opened. This may be a good option to check just in case the original data has changed while the PivotTable was closed.

- **Grand Totals** – Grand totals will display on every PivotTable created by default. To not display Grand Totals by default, uncheck the Grand Totals option from the Totals & Filters tab.
Report Layout
By default, a PivotTable is shown in the Compact Form layout. Compact Form layout does not display descriptive names for column or row labels, nor does it indicate that the top line on a row displays the total for that row.

To change the labels to allow for a more descriptive label on columns and rows and an indication of the totals, make sure the cursor is within the PivotTable, and then navigate to the PivotTable Tools Design tab. On the left side of the Ribbon in the Layout group, click on the Report Layout dropdown.

The two other options available are Outline Form and Tabular Form. Either of these options will provide a more descriptive name for both row and column labels, but the major difference is Tabular form will place more emphasis to Subtotals, which will be located on the bottom of the group, whereas Outline will display the subtotals on the top of the group.

Outline Form

Tabular Form
Subtotals and Grand Totals
The Subtotal and Grand Total will display the subtotal for each field and the overall grand total by default in a PivotTable.

To turn off the subtotal option for a group, or to change the location of the subtotals, navigate to the PivotTable Design tab, click on the Subtotals dropdown and select the appropriate option.

To turn off the Grand Total option for a group, or to change the location of the grand totals, navigate to the PivotTable Design tab, click on the Grand Totals dropdown and select the appropriate option.
**Blank Cells**
Blank cells may cause problems within a PivotTable if the data ends up being a row or column heading. Sometimes, blank data is significant to the data displayed in the PivotTable, so blank cells are needed to represent the data correctly.

By default, all blank cells within a PivotTable will display as blank, or as an empty cell. Depending on the type of data that is being displayed, it may be best to change the blank cells into a value. If the data is displaying Sales, it may be best to display the blank data as a zero to show that there weren’t any sales for a particular day, region, etc. To change the display or blank cells, right click within the PivotTable and selecting PivotTable Options.

**Tip:** PivotTable options may be selected by navigating to the PivotTable Tools Analyze tab and then select PivotTable options on the left side of the ribbon.

On the PivotTable Options window, navigate to the Layout & Format Tab. On the bottom of the window in the Format section, make sure there is a checkmark next to the For empty cells show: option. In the textbox, enter in the value to display in all blank cells.

**Refresh Data in a PivotTable**
The data within a PivotTable is not automatically updated when the original data has been changed. Anytime any of the original data is changed, a PivotTable must be refreshed to display the newly updated data.

To refresh the data in a PivotTable, navigate to the PivotTable Analyze tab, select the Refresh icon and then choose Refresh All.

**Note:** Refresh will only update the data from the source connected to the active cell. Refresh All will refresh all data within the current workbook.

**Tip:** The shortcut to Refresh All is Ctrl-Alt-F5.

Refresh data may also be turned on to refresh any time a file is opened. On the PivotTable Tools Analyze Tab, select Options, which will be located under the PivotTable Name text box.
**Note:** Depending on how wide the Excel window is, Options may not display immediately. If Options isn’t visible, click on the PivotTable icon on the left side of the screen and then select Options.

From the PivotTable Options dialog box, select the Data tab and then check the option to Refresh data when opening the file.

**Format PivotTable Data**

PivotTables do not carry over the formatting applied to the source data. All formatting in a PivotTable must be applied to the data in the PivotTable.

To set the formatting for an entire field (column) in a PivotTable, right click on any cell within the column, and then select Number Format. From the Format Cells dialog box, select the appropriate data type and click the OK button.

**Note:** When a cell in a PivotTable is right clicked on, there is an option to format cells. When selecting this option, formatting will only be applied to the selected cell, not the entire column.
The Field Settings drop down menu may also be accessed from the PivotTable Analyze tab.

1. Make sure the cursor is in a cell in the column to be formatted.
2. Select the PivotTable Tools Analyze Tab.
3. Click on Field Settings on the left side of the ribbon.
4. On the Value Field Settings Dialog box, select the Number Format button in the lower left side of the dialog box.
5. On the Format Cells window, select the format for the cell(s)
6. Click OK to apply the changes to the cells.
Change the Value Settings
By default, Excel sets the Value of “sum” to a field added in the Values area of a PivotTable. This value may be changed to several different options including; average, maximum, minimum, and/or count.

On the PivotTable Fields area, click on the drop-down menu on a field that is currently in the Values section and then select the Value Field Settings option.

On the Value Settings dialog box, select the appropriate option; Average, Max, Min and then click the OK button.
Show Totals as a percentage
When looking at data in a PivotTable, it may be useful to represent the data as not only a number, but also a percentage of the overall total. For example, the data shows a breakdown of salary by department, but it may be nice to see not only the total dollar amount for each department, but also the total percentage of the total salary for each department.

If a PivotTable only has Sum of Salary within the Values area, it will look like this;

To display this field as another display type, click, hold, and drag the Salary field from the PivotTable Fields section into the Values area a second time. The PivotTable will now display the Salary as a Sum just as below.
To change the display of the second Salary value to a percentage, right click on a cell in the Sum of Salary2 column, choose Show Values As and then choose % of Grand Total.

The PivotTable will now display the Departments, with the Total Salary per department, as well as the percentage of the total salary per department.

**Rename Column Field Names**
The column field names are not very descriptive which can make it tough for individuals to decipher what is being displayed. For example, in the example above, the column headings look like this;

When looking at the column headings a more descriptive name, especially the Sum of Salary2 column, would be very beneficial. To change a heading name, simply click on the cell and type in a new name.

This can be done on any field name within a PivotTable (column headings from the original data), but the columns cannot have the same name as a PivotTable field name. For example, if the Sum of Salary name was changed to just Salary, Excel would produce an error stating the field name already exists.

To use the same name as an existing field name, add a space after the name. The extra space won’t be visibly noticeable and Excel will accept the new name since it does not match a PivotTable field name exactly.
Sort a PivotTable

To sort the data in a column, position the cursor in the field to be sorted and select either the Ascending or Descending Sort icon from the either Data tab, or the Home tab, editing group.

A multi-level sort may be performed as long as there are multiple levels within the PivotTable. To perform a multi-level sort, each field within a field section will have to be sorted individually.

For example, if a PivotTable is set up with a Department and Employee Name in the Rows with the Salary displayed in the Values area.

To sort this data by Department name and then by descending employee name, the department name must be sorted first. Position the cursor within a cell of one of the department names. Navigate to the Home tab, click on the Sort and filter button, and select the Sort A to Z option. This will only sort the Department name alphabetically.

To sort by the employee names within each department, select a cell containing an employee name. Navigate to the Home tab, click on the Sort and filter button, and select the Sort Z to A option.

The data will not change the sort of the Department names since the department name is on a different level than the Employee name.

Note: This data could also be sorted by the salary, but that would override the sort that was performed on the employee names since they are both on the same level within the PivotTable.
Expand/Collapse Data

If the data within a PivotTable has multiple fields within a Row area, there will be a small + (plus) or – (minus) button that will display to the left of the top Level fields.

The plus or minus buttons indicate if the data is collapsed (plus) or expanded (minus). To expand or collapse a field, click on the plus or minus button to the left of the field names in the PivotTable.

Another way to expand or collapse the data is to place the cursor in the field to expand or collapse. Navigate to the PivotTable Analyze tab, and then click on either the Expand or Collapse icons that are located in the Active Field group, on the left side of the ribbon.

Drill Down

A PivotTable is a summary of data that may represent one or many records from the original data. Drill down is a feature that will display the individual data that makes up that summarized data and display that data on a new sheet.

In the example below, each department is displayed with the total salary of every employee within that department. The drill down feature can be used to display each employee and their salary from an individual department. To see a list of employees from an individual department, double click on one of the cells that contains a total salary.

Excel will insert a new sheet to the right of the currently selected sheet which will display the individual data that makes up the summary of the cell that was clicked on.

Note: If the data in the PivotTable changes, the drill down sheets will not update, even if the Refresh all button on the PivotTable Tools, Analyze tab is selected.
Group Data by date/time
PivotTables have the ability to Group Selections by date and time.

1) Start by positioning the cursor in a column containing a date or time.
2) Navigate to the PivotTables Analyze tab
3) Select Group Field.

4) Verify that the Start and End dates are correct in the Grouping window and then select the data to sort on from the By section of the Grouping window.
5) Click on the OK button.

Note: Grouping may be done on multiple data points; Months and Years, Days and Months, etc.

To remote grouping, navigate to the PivotTables Tools Analyze tab and select the Ungroup Data button.

Tip: Grouping options are also located in the context sensitive menu when you right click your mouse on the date data.
PivotTable Timeline

The Timeline feature, which was introduced in Excel 2013, allows users to filter a PivotTable by using a Timeline. In order to use the Timeline feature, the data must have dates.

Start by selecting a cell that contains a date. Navigate to the PivotTable Analyze Tab, and then click on the Insert Timeline icon.

Excel will display any fields that are available to use with the Timeline feature on the Insert Timelines window. Place a checkmark in the box next to the field name to add to the timeline, and then click OK.

**Note:** To change the size of the timeline, make sure the timeline is selected and then click, hold and drag on one of the placeholders to resize the timeline.

The timeline will appear on the sheet displaying the data in a time period, dependent on the data that is selected, Year, Months, Days, Hours, etc.

On the upper right side of the timeline, the time period will display how the data is filtered on the timeline. To change the time period, click on the drop down and selecting the appropriate option.

To filter the timeline into a specific time period, click on the timeline bar to select a range to filter the data. As options are selected on the timeline bar, the data in the PivotTable updates to reflect the time periods that are selected.
To select a range on the timeline, click, hold and drag on the blue bar to make a larger selection.

Create a Calculated Field

A calculated field is a manually created field within a PivotTable that is used to preform calculations. The calculated field must reside in the data area. The formulas used are stored in a dialog box and stored within the PivotTable data.

To create a calculated field, make sure the cursor is within the PivotTable. Navigate to the PivotTable Analyze tab, click on the Fields, Items & Sets drop down and then select Calculated Fields.
On the Calculated Field dialog box, provide a name for the new field in the Name textbox. Navigate to the Formula textbox and place the cursor just after the equal (=) sign. To add a field into the formula, double click on the field name from the list of Fields in the middle of the window. After adding in a field name, make sure to manually add in a mathematic symbol (=, -, *, /, etc.) to perform a calculation with the data in the fields.

Click OK when the formula is complete.

The new column will be added to the right of the PivotTable, with the result of the formula displayed.

**Edit a Calculated Field**

To edit a calculated field, make sure the cursor is within the PivotTable. Navigate to the PivotTable Analyze tab, click on the Fields, Items & Sets drop-menu and select then Calculated Fields.

On the Insert Calculated Field window, click on the dropdown on the right side of the Name textbox to display and select the calculated field.

The Formula for the calculated field will appear in the Formula text box where any additions, deletions, etc. may be made to the fields, type of calculation, etc.

When the changes have been made, click on the OK button to update the field.

**Tip:** Static Numbers into the formula as well. To add $10,000 to each Total, add a + 10000 to the formula.
Print a PivotTables

Insert a Page Break after a Row Label
If the data in the PivotTable has more than one row label, meaning there are multiple categories on the left side of a PivotTable, a page break may be inserted at each row label so when the PivotTable is printed, each new category will have its own page.

To add a page break after each new row item, right click one of the names within the category and then select Field settings.

For example, to print a new page for each new department, right click on one of the department names and then select Field Settings.

Tip: The Field Settings tool is also location on the PivotTable Design tab.

On the Field Settings dialog box, select the Print and Layout tab. On the bottom of the dialog box under the Print section, place a checkmark next to the Insert page break after each item option.

Any time the row name changes, a new page will print.

Print Titles in a Report
By default, the Titles on the top of a PivotTable will only print on the first page.

To print the column headings on the top every printed page, right click within the PivotTable and select PivotTable Options from the Menu.

Tip: PivotTable Options is also located on the PivotTable Design tab, PivotTable Options drop-down menu.

On the PivotTables Options dialog box, select the Print tab. Select the check box next to Set Print titles and then Click OK. This will make the first row repeat on each page that is printed.
Insert a PivotTable Chart

Data in a PivotTable can easily be converted to a PivotChart for a better visual display. To insert a PivotChart, make sure the cursor is within the PivotTable and then select the PivotChart button in the Tools Group.

The Insert Chart window will appear which will display all of the chart options that are available. To view a preview of a chart, click on the chart type on the left hand side.

When the correct chart is selected, click the OK button to add the chart to the worksheet.

When a PivotChart is selected, the PivotChart Tools tab appears on the ribbon.
Edit a PivotChart
When a PivotChart is selected, there will be two icons that appear on the upper right side of the chart. These icons can be used to add in chart elements, change the color or style, etc. of a chart.

Chart Element
The plus icon allows Chart Elements, chart title, data labels, etc. to the chart. To add an element to the chart, place a checkmark next to the element name.

Chart Style
The paintbrush icon, will include options for the Chart Styles and the chart colors.

Note: Each chart type will display the styles differently. Remember to use the scrollbar to see all options that are available for a particular chart type.

To change the color of the chart, click on the Color tab to select a new color scheme.

Change Chart Type
To change the chart type, make sure the PivotChart is selected, navigate to the Design tab, and then select the Change Chart Type icon.

On the Change Chart type window, select the appropriate chart type and then click OK to change the chart.
Slicer Tool
The Slicer tool is used to filter the data in PivotTable/PivotChart. The Slicer tool is a visual way of filtering data, vs using a filter dropdown menu.

Insert Slicer
To insert a Slicer, make sure the cursor is within the PivotTable. Navigate to the PivotTable Analyze tab and then click on the Insert Slicer button.

The Insert Slicers window will appear which will display all fields that are in the PivotTable. Place a checkmark next to the field(s) to add that slicer and then click OK.

Excel will populate a new slicer, in its own window, for each field that was selected.

To use the slicers, simply click on the item to display. When an item is selected (highlighted) the PivotTable will update to reflect what was selected.

To select multiple items from a slicer, click on the first item, press and hold the Ctrl key and then click on the next item.

To remove a slicer filter and display all items on the slicer, click on the Clear Filter icon on the upper right side of the slicer.

To add a new slicer, make sure the cursor is within the PivotTable or the PivotChart is selected. Navigate to the Analyze tab and click on the Insert Slicer icon, place a checkmark next to the field to be added and then click OK.

Delete a Slicer
To delete a slicer, click on the slicer to select it and hit the delete key.