Microsoft Word 2007 - Creating and Editing Tables

Tables can be used to organize and display text and graphics within a document. A table can be created so that information is displayed neatly in rows and columns, or it can be customized so that each cell can vary in size to accommodate text and graphics. Existing text in a document can also be selected and easily converted to a table where the data will be placed in cells according to the table dimensions you specify.

Insert/Create a Table
Add a simple table to your document by choosing the Insert tab, Tables group, Table drop-down, Insert Table option.

Specify the number of rows and columns you want from the Insert Table dialog box.

Selecting Parts of a Table

<table>
<thead>
<tr>
<th>Part</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell</td>
<td>Click the left edge of the cell</td>
</tr>
<tr>
<td>Row</td>
<td>Click to the left of the row</td>
</tr>
<tr>
<td>Column</td>
<td>Click the column's top gridline or border. Watch for the arrow □ and then left-click the mouse to select the column; or, no matter where your cursor is located in the column, hold down the ALT key and left-click with the mouse to select a column.</td>
</tr>
<tr>
<td>Multiple cells, rows, or columns</td>
<td>Left-click the mouse and hold while dragging across the cell, row, or column; or select a single cell, row, or column and then hold down SHIFT while you click another cell, row, or column.</td>
</tr>
<tr>
<td>Entire Table</td>
<td>Select an entire table by clicking on the Select Table icon that is located above the top-left border of the table.</td>
</tr>
</tbody>
</table>

Note: The document must be in Print Layout View before you can use the Select Table button.

TIP: You can also select rows, columns, or the entire table by choosing the Select icon drop down menu from the Layout tab, Table Group.
**Displaying or Hiding End Marks**

Word can display end-of-cell marks to indicate where the contents of a cell end and end-of-row marks to indicate the end of the row. To turn these marks on or off, click the Show/Hide icon located on the Home tab, Paragraph group.

![Diagram showing end marks and table features](image)

**Entering Text**

<table>
<thead>
<tr>
<th>Add Text</th>
<th>Navigate to a cell and add text. Text can be formatted using the Home tab and/or the Table Tools tab, Design and Layout tools.</th>
</tr>
</thead>
</table>

**Navigating Keys**

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab key</td>
<td>The Tab key will navigate one cell to the right.</td>
</tr>
<tr>
<td>Arrow keys</td>
<td>The Arrow keys will navigate in the direction of the arrow key selected.</td>
</tr>
<tr>
<td>Mouse Cursor</td>
<td>Click in a cell with the Mouse Cursor.</td>
</tr>
<tr>
<td>Shift + Tab key</td>
<td>The Shift + Tab key will navigate one cell to the left or back one cell.</td>
</tr>
<tr>
<td>Ctrl + Tab key</td>
<td>Ctrl + Tab key will insert a tab in the cell.</td>
</tr>
<tr>
<td>Alt + Home key</td>
<td>The Alt + Home key will navigate to the start of a row or first cell in the row.</td>
</tr>
<tr>
<td>Alt + End key</td>
<td>The Alt + End key will navigate to the end of a row or last cell in the row.</td>
</tr>
<tr>
<td>Alt + Page Up key</td>
<td>The Alt + Page Up key will navigate to the top of the column.</td>
</tr>
<tr>
<td>Alt + Page Down key</td>
<td>The Alt + Page Down key will navigate to the bottom of the column.</td>
</tr>
<tr>
<td>Enter key</td>
<td>Press the Enter key to navigate to a new line within a cell.</td>
</tr>
</tbody>
</table>

**Adding, Rows, Columns, and Cells**

Rows, columns and cells can be added at any time with ease to a table. Position the cursor where a row or column needs to be inserted and choose the tool from the Table Tools, Layout tab, Rows and Columns Group of the Ribbon. Insert and select either Row Above, Row Below, Column to the Left, Column to the Right or Cell.

**TIP:** Word will insert rows, columns and cells according to the number of rows, columns or cells that are selected.

**TIP:** You can also Right-click the mouse in the table and select Insert, Rows/Columns/Cells.
CAUTION: Adding cells to a table is just as easy, but if not done correctly the result can alter the table and shift information where it may not be accurate anymore.

Deleting Tables, Cells, Rows, Columns or Content
You can clear the contents of cells without deleting the cells themselves by selecting the information in the cell(s) and pressing the Delete key.

Deleting cells in a table
Select the cells you want to delete and choose the Delete icon from the Rows and Columns group of the Table Tools, Layout tab.

CAUTION: Deleting cells in a table can be done, but if not done correctly the result can alter the table and shift information where it may not be accurate anymore.

Deleting a Row or Column

Column
Position the cursor above the Column border and click to select the column. Next, choose the Delete icon from Table Tools, Layout, Rows and Column Group.

TIP: You can also right-click your mouse and choose delete from the context sensitive menu.

Row
Position the cursor to the left of the Row border and left click to select. Next, choose the Delete icon from Table Tools, Layout, Rows and Column Group.

Resizing Columns and Rows
The quickest way to resize a column or row is to drag the border of the row or column to the size needed.

Column and Row size can also be adjusted by using AutoFit from the Table Tools, Layout tab, Cell Size Group.
Defining the AutoFit Attributes

**AutoFit to Contents**
This makes each column just wide enough to accommodate its longest entry.

**AutoFit to Window**
This stretches the table so that it fits across the page between the left and right margin.

**Fixed Column Width**
This fixes the column widths at their current settings.

**Distribute Rows Evenly**
This makes all rows the same height as the tallest row.

**Distribute Columns Evenly**
This makes all columns the same width.

**Table Properties**
Table Properties can also be used to set or modify table, cell, row, column properties. Properties include table alignment, row height, column width and text alignment options.

The Table Properties icon is located in the Table Tools, Layout tab, Table group.

**Gridlines**
Tables by default have a ½-pt black, single solid-line border around each cell that prints.

To remove/display the border from view only, choose **View Gridlines (this is a toggle feature)** or **Hide Gridlines** from the Border icon drop-down located on the Table Tools, Design Tab and/or the Home tab, Paragraph group.

**TIP:** the Outside Border icon must be set to “None” in order for this to work.

If you set your table borders to “None,” you still see gridline guides for editing purposes. However, when you print, the gridlines will not display. To hide the gridline guides while editing, deselect View Gridlines from the Layout tab.
Add Borders and Shading to a Table
Borders and Shading can be added to a table by using the Table Tools, Design tab, Borders tools from the Table Styles group. NOTE: the Border tool is also located on the Home tab, Paragraph group.

TIP: When using the Borders and Shading menu, be sure to specify how the border and shading should be applied by selecting cell or table from the Apply to field.

Remove Borders and Shading from a Table
Remove all borders and shading from a table by choosing Clear from the Table Tools, Design tab, Table Styles Group drop-down menu.

Apply Table Styles
Pre-built table styles can be applied to any table. The Table Styles are located on the Table Tools, Design tab, Table Styles Group.

Merge/Split Cells
You can combine (or split) two or more cells/columns/rows by using the Merge tools on the Table Tools, Layout tab, Merge Group.

1. Select the cells you want to merge or split.
2. From the Ribbon, choose the appropriate merge tool.

Sorting a Table
Sort the entire table by first positioning the cursor in the table. Next, select the Sort tool from the Table Tools, Layout tab, Data Group area of the Ribbon.

Select the sort options from the Sort Dialog box and choose OK when finished.

Number the Cells in a Table
Select the cells you want to number in a column and choosing either the Numbering or Symbol icon from the Home tab, Paragraph Group of the Ribbon.

TIP: the Mini Toolbar can also be used to add bullets.
Repeat a Table Heading on Subsequent Pages
You can have Headings repeat on subsequent pages for tables that span multiple pages. Select the row of text that you want to use as a table heading. **NOTE:** the selection must include the first row of the table. Next, choose Repeat Header Rows from the Data Group of the Table Tools, Layout tab.

Convert Existing Text to a Table
You can easily convert existing text into a table if the text has been separated by Paragraph, Comma or Tab separators.

Select the text you want to convert and choose Insert Tab, Tables Group, select drop-down menu and choose Convert, Text to a Table.

Convert a Table to Text
Select the entire Table you want to convert. Select the Layout tab in the ribbon, click “Convert table to text”

Split a Table
Place your cursor in Row 1 of the New Table section. From the Table Tools, Layout tab, Merge group, choose “Split Table.”

Cell Alignment, Margins and Text Direction
Every cell in a table behaves like its own page with its own margins and alignment. You can change cell margins and alignment for either the entire table or for selected cells. By default, the alignment and margins for cells in a table are identical. However, if you select a built-in style, you may affect text alignment.

You can change text alignment for a cell, a group of cells, or the entire table by choosing one of the text alignment buttons in the Table Tools, Layout Tab, Alignment group.
You can also right-click on a cell or an entire table and choose Cell Alignment.

You can change the default cell margins by selecting the table, clicking the Layout tab, and choosing Cell Margins from the Alignment group.

Other Ways to add Tables to Your Document

Other ways to add a table to your document can be found on the Insert tab, Tables Group, Table icon drop-down menu.

- **Insert Table** – drag mouse over number of rows/columns
- **Draw Table** – drag your table, rows, columns, and cells

Draw a Table

Draw a custom table on your document by clicking the Insert Tab, Tables group, Table drop-down menu and selecting Draw Table. Start by drawing a border and then adding rows, columns and cells. You can even draw diagonal lines. Use the Eraser tool to erase lines in the table.
More Table Tips

Adding a Title Line:
To add a title line above a table which has been inserted as the FIRST object on a page:
   1. Click in the upper-left cell in the first row of the table. Note If you have text in the
      upper-left cell, place the insertion point before the text.
   2. Press ENTER.
The table will drop down a line so that a title can be added.

Powerful Right-Click Options
As you experiment with the tables in your Word document, don’t forget to do a little right-
clicking. Just about everything you can do to a table cell is accessible on the shortcut menu that
appears when you right-click the cell. Different combinations of commands appear depending on
whether you select a single cell, a range of cells including an entire column or row, or an entire
Table.

Using Tabs in a Table
You can set tab stops for individual cells or a range of table cells. Tabs in tables work pretty
much the way they do outside of tables, with two important exceptions:
   1. To insert a tab character into a cell, you must press Ctrl+Tab. Simply pressing the Tab
      key moves the cursor to the next cell without inserting a tab.
   2. If you add a decimal tab to a table cell, the text in the cell automatically aligns over the
decimal tab. (A decimal tab is a tab that aligns numbers on the decimal point.) You don’t
      have to press Ctrl+Tab to move the data to the tab stop.